Internal Engine Cams | Heads | Rotating Assemblies

Got problems need help

Old 10-31-2008, 09:05 AM
  #1  
On The Tree
Thread Starter
iTrader: (1)
 
Join Date: Aug 2005
Location: N.C.
Posts: 191
Default Got problems need help

A blue oval buddy of mine has a 2000 F-150 w/ a Harley Davidson series blower on it. It ran strong for about 9000 miles but now the power and boost goes away after 1/2-3/4 throttle. We changed the MAF and fuel pumps to no avail.. The transmission has been having a tough time lately it has about 110,000 miles on it. IMO the power loss is from the converter or transmission.
Any suggestions?
Iraq Sucks is offline  
Old 11-20-2008, 01:51 PM
  #2  
12 Second Club
iTrader: (3)
 
02b4ccamaro's Avatar
 
Join Date: May 2008
Location: new orleans, la
Posts: 151
Default

sound dumb but have you change the fuel filter, a friend of mine had a f150 w/a 5.4 that have the same problem we almost put a trans in it but it turned out it was the fuel filter.
02b4ccamaro is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hotrodwayne
Chassis & Drivetrain
0
02-13-2009 01:05 AM
HYBRED
Chassis & Drivetrain
0
07-13-2006 03:14 PM
hardtohitme7
External Engine
11
05-12-2006 04:58 AM
Quick86
Internal & External Engine
4
04-23-2006 11:28 PM
TJs98GT
General Maintenance & Repairs
6
03-31-2006 01:33 PM


Thread Tools
Search this Thread
Quick Reply: Got problems need help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.