Diablo sport loosing power. - Mod Motor Tech Forums

Fuel Injection & Tuning DiabloSport | HyperTech | TwEECer | SuperChips | HP Tuners

Diablo sport loosing power.

Old 04-25-2006, 09:34 PM
  #1  
Moderator
Thread Starter
 
blueeyeddevil's Avatar
 
Join Date: Sep 2003
Location: hanford/ ca
Posts: 107
Default Diablo sport loosing power.

I run a Diablo sport tuner, and have their performance tune in my car. I have not dynoed my car to know for sure, but always feel that after a few months it seems to lose power. After reflashing it, it seems to have more pep and better throttle response. When I watch the live data it shows an 8% long term fuel trim, is that about right and have any of you guys experienced similar problems?
blueeyeddevil is offline  
Old 04-28-2006, 01:52 PM
  #2  
TECH Resident
iTrader: (2)
 
blackfang's Avatar
 
Join Date: Jul 2002
Location: Richmond, VA
Posts: 883
Default

Wish I could help, but I run SCT.

I would check out www.modularfords.com and speak with Chris Johnson who actively posts in the Diablo section.
blackfang is offline  
Old 05-24-2006, 06:29 PM
  #3  
Administrator
 
unit213's Avatar
 
Join Date: Jan 2002
Location: Earth
Posts: 45,815
Default

The tune is the same. Reflashing the same tune shouldn't make any difference.
You should get a custom tune...assuming that one is a mail order deal.
unit213 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
carid
Sponsor Specials & Group Purchases
0
12-17-2014 11:12 AM
moregrip
For Sale
1
10-13-2006 12:49 PM
hamood666
Fuel Injection & Tuning
9
04-14-2006 09:32 PM
HYBRED
General Maintenance & Repairs
1
03-09-2006 09:35 PM


Thread Tools
Search this Thread
Quick Reply: Diablo sport loosing power.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.